MAAS crashing after a couple of days

My snap installed MAAS web UI is showing this error after a few days of being left alone

builtins.OSError: [Errno 24] Too many open files: ‘/snap/maas/18199/usr/share/maas/web/static/index.html’

The problem can be cleared by running
sudo snap restart maas.supervisor

What is a good way to diagnose this? Thanks.

So its happening more often now, a few hours after a restart.

This is the snap version 3.1.0.

When this happens I see:

  • Failed to contact region. in the rackd log.
  • The regiond log seems to show no errors.
  • The maas logs show errors connecting to the power webhook (because my webhook server is offline right now).
  • named.log is showing many errors I don’t understand.

Logs attached.

Hi @gilesknap,

you seem to have a DNS configuration issue that is exhausting the TCP ports inside the snap jail. You can try going to Settings > Network > DNS and disabling DNSSEC, or trying a different upstream server.

Awesome thanks. I was using Open DNS and have switched to Google since I don’t really need the filtering for my MAAS devices. Will report on the results.

Crashed again when I looked this evening (with DNS upstream as

Will now try disable DNSSEC.

I’ve switched to Google for upstream DNS and turned off DNSSEC. But still have MAAS crashing after several hours running.

I’ve noticed that the server on which I’m running seems to be pointing at itself for DNS and that seems a bit wrong ( is the server’s own IP) :

giles@vmaas1:~$ systemd-resolve --status
       LLMNR setting: no                  
MulticastDNS setting: no                  
  DNSOverTLS setting: no                  
      DNSSEC setting: no                  
    DNSSEC supported: no                  
  Current DNS Server:        
         DNS Servers:        
Fallback DNS Servers:             
          DNS Domain: maas                
          DNSSEC NTA:     

I’ve done apply netplan with the following yaml but this has not changed the above

giles@vmaas1:~$ cat /etc/netplan/00-installer-config.yaml 
# This is the network config written by 'subiquity'
  version: 2
  renderer: networkd
      dhcp4: false
      addresses: []
        addresses: [,]

Is this a problem or just a red herring?

I don’t think it is wrong to point the host at itself for resolution if you are running a DNS resolver such as MAAS. In fact, this is the easiest way for you to be able to resolve maas managed domain names from the maas server.

see this diagram from this thread:

I know I’m not answering your quesion/issue, just commenting on the dns setup.

Thanks Anton, now I need another theory as to what the problem is :slight_smile:

This looks to be resolved.

I had a rogue copy of K3S Agent running in the VM alongside MAAS. I must have accidentally installed it. I’m not sure of the exact problem but removing that seems to have fixed it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.