MAAS 3.3 dhcdp process not running?

Hi all,

I am trying to launch MaaS 3.3 on a Single VM (both rack and region controllers) with the new ansible playbook scripts which worked ok but the DHCPD server doesn’t seem to be running:

Although DHCP is enabled for the VLAN:

Also no process listening on port 67 on the maas vm.

Network wise everything is great because if i down this VM and bring up another one I had with version MaaS 3.1 everything is working as it should.


Hi @jonaspaulo
Can you provide a bit more information about MAAS version that you are using? I see it is a 3.3 but knowing a specific build info would help.

Also would help:

  • OS version where MAAS is deployed
  • Is it a snap or a deb package?

Sorry Troy here you go:
Following from:

ansible-playbook -i ./hosts --extra-vars=“maas_version=3.3 maas_postgres_password=XXXX maas_installation_type=deb maas_url=http://x.x.x.x:5240/MAAS” ./site.yaml

MaaS Version installed: 3.3.0~rc1
OS Version: Ubuntu 22.04.1

(I have also tried already with maas_version=3.2 which installs version 3.2.6 and same dhcp “issue”)


with manual install via snap (at least on version 3.2.6) it works:

@jonaspaulo, is this resolved for you? it’s a little unclear where you’re at with this one, don’t want it to fade into unresolved obscurity…

Seeing the same Issue when using the ansible playbooks from current master.

I created an issue at the github repo for the ansible playbooks here:

1 Like

sorry just used the manual install afterwards

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.