MAAS 2.8 LXD pods

Enlistment v. Commissioning is a great detailed explanation of how commissioning and enlist differ, and why (please incorporate it into the documentation!) however, the title seems a bit off. However, I found it as I was trying to figure out how to self host … due to Covad, I’m setting up my laptop to kick 2.8’s tires … and I wanted to use the system (either linux small laptop, or mac under virtualbox) to self host … region+rack, db … and the LXD host. I found the LXD option under KVM (which seemed a little odd) but what’s the LXD address? for kvm it was qemu+ssh … (it would be a kindness to have the UI provide the template … or perhaps it’s my browser’s attempt to fill in credentials that’s misfiring …).

@khbkhb, i moved your post to discourse for discussion, that’s the best way to get an answer.

1 Like

The full address would be https://$FQDN_OR_IP:8443 however when we implemented LXD we made MAAS smart enough so you only have to enter the FQDN or IP, MAAS fills in the rest on the backend.

1 Like

Thank you. I guess I must have some other issue, as

ip addr ....2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:23:9e:1d brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute enp0s3

LXD Address. and are receiving “failed talking to the pod” Localhost fails as well.
… after trying all the permutations … it appears lxd init has to be executed first (I had executed it, but I’d tried filling in the MAAS info in the interactive dialog and that failed … but lxd init without configuring MAAS for lxd, and then filling in the address as suggested in MAAS works.

Thank you!

Follow on oddity. When creating a new VM, haven’t created a second network (figuring that with just LXD, I wouldn’t need it) creating a KVM/LXD pod, it shows up as “power unknown” is that expected? If so, why? (wouldn’t LXD suffice for start stop, corresponding to power on/off?"

Composition works, commissioning starts (so it could “power up” after all) but it fails with “smartctl-validate” but the log is empty.

Further experiments, updated to 2.8rc1. Ubuntu 20.04 as the host. Installed lxd, and kvm. Created a VM to be the region/rack controller. Configured lxd and verified operation as per this article. That is, from the VM hosting the region controller (vmaasrack),
lxc launch ubuntu:20.04 lhost:bork
Creating bork
Starting bork
khb@vmaasrack:~$ lxc exec lhost:bork bash
root@bork:~# ls
and lxc list on the host agrees …

Setting the same host as the LXD host inside of maas works, and composition kicks off but seems to spend forever in commissioning …
khb@vmaasrack:~$ lxc exec lhost:flint bash
Error: Failed to connect to lxd-agent

And the same error using lxc from the host. Where might one find logging about what’s getting hung up?

Now that the 2.8 docs have been updated, I’ve found my issue. Following the instructions about LXD init works (note carefully the “use existing bridge” bits). Without these instructions, I’d naively accepted the default of creating a new one …

Kudos to the writers, this was exactly what was missing.

1 Like

thank you! glad the doc was helpful, glad you found your answer!