MAAS 2.5 won't PXE Qlogic 10G nic HP model# NC523SFP


#1

Hi,

Trying MAAS 2.5 on bare metal, notice maas 2.5 won’t PXE boot this type of nic card’s Model: NC523SFP running firmware version 4.20.1 the servers are HP DL380e G8 System ROM P73 05/21/2018. If anyone know how to fix this issue I’d be really grateful Thanks.

Here’s an image on where the systems han

g


#2

What method did you use to install MAAS? Installing Via Snap currently has a bug which breaks pxebooting.


#3

Packages.
sudo apt-add-repository ppa:maas/stable
sudo apt install maas

Just to let you know the 2.4 version work fine!


#4

Hi,
I’ve the same issue with Mellanox Technologies MT27500 Family [ConnectX-3] cards.

Stuck at the same point


#5

Hi all,

a full console log would be helpful to try to understand what could be going wrong.

That said, I wouldn’t be surprised if this is firmware related, but a full console log (or video) might just help.


#6

We had same problem with couple servers only when we switched to 2.5 (we were @ 2.4), we have fixed getting the latest firmware and replacing the DACs.

We replaced the DACs as after the firmware upgrade as we started to see errors and warnings coming from the NIC driver, then switched back to 2.4 and then no errors! So we hear guy was blaming Chrony causing some problems with some switches in a different deployment, so we decided to check the DACs and as we suspect those were different than the others in that cab. We replaced with Mellanox, after the replacement everything worked fine.

Regards,