How to enable DHCP server?

I’m trying to setup MAAS in an environment with two networks, one for a private VLAN and another for a public VLAN. This environment prevents servers from accidentally being installed via PXE, but is a challenge to set up. It is similar to what’s described at

However in my case the Dell server boots into PXE boot mode but never attempts to obtain a DHCP address, One thing that bothers me is that in Settings → Network → Private network (or fabric), DHCP is set to External instead of MAAS Controlled, and I seem to have no way to change this. I don’t even recognize the external DHCP server and it’s probably not safe to use.

Is there any way I can force MAAS to use MAAS controlled DHCP server? MAAS is running a DHCP server. I already have a reserved range, but interestingly there is no option to select MAAS provides DHCP as explained at

I’m using MAAS 3.4.2.

I was able to resolve this issue by attaching a power cable to the redundant power supply. Based on the output in the server console, I had a hunch that this might have something to do with my issue, but wasn’t sure. After attaching the power cable to the other power supply, the server started to do the DHCP broadcast on the interfaces and now the server is in MAAS.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.