Disable automatic enlistment/commission and shutdown

This was previously posted and ‘closed’ with a solution so I was unable to reply to that posting. The solution posted does not work.

There are multiple servers that need to boot from their internal hard drives and not from PXE/MAAS. How-ever I do not want to turn off PXE as this is a fall back solution if the drives fail or troubleshooting is needed on the server.

The solution posted was

Disable automatic enlistment/commission and shutdown

root@maas:~# maas $PROFILE maas set-config name=enlist_commissioning value=false
Machine-readable output follows:

I took a server that was not in MAAS and I rebooted and it went into a PXE boot and then enlisted in MAAS, which is supposed to be turned off. Is there any option for this? I was hoping I could add it as a ‘device’ and MAAS would ignore it. But that does not work either.

MAAS running via snap 3.3.2-13177-g.a73a6e2bd

Hi @kbm1, I was never able to find a solution for this either, the ticket was closed before I was able to test the proposed solution. Now that I have tested it, it does not work. We’re currently working around the unexpected power offs by only pointing boot options at MaaS for individual machines, rather than for the entire Subnet, so that machines are not PXE booted off of MaaS unintentionally, without first being added.