Disable automatic enlistment/commission and shutdown

Is there any way to disable the automatic enlistment/commission->shutdown process for machines which have not been added to MaaS, but do attempt to PXE boot to the MaaS Rack Controller? We’re using an external DHCP service, and pointing one of it’s subnets to the MaaS Rack Controller using boot options 66/67. This is working well for machines which we allow MaaS to control from end to end.
However, there are cases where our hardware installation team would like to manually image a machine on the subnet for purposes of hardware debugging or initial setup. It causes a great deal of confusion, especially if they’re a new member, when a machine continues to automatically shut itself off after every boot attempt.

Ideally in our scenario, once a machine has been commissioned, MaaS would allow it to just continue on to it’s OS on the next boot, and if a machine has not yet been added to MaaS, it would not automatically enlist.

Thank you very much for any pointers, your help is greatly appreciated!

@benhunt, you do have the option, on commissioning, of leaving the machine on after commissioning. would that help?

@billwear I do have the option to do so. Is it possible to leave it up booted from it’s OS on disk, or will it be booted from the ephemeral commissioning OS?

commissioning erases the OS on the disk and replaces it. sounds like that may not be what you want.

You’re correct - ideally it would not overwrite the OS unless deploy or commission is requested. I’m sorry we have such a unique use case for you!

My goal would be that if a machine is not added to MaaS but PXE boots off the rack controller, it would be ignored entirely - not receive a new OS, and not automatically shut itself off.

there is a way to turn off auto-commissioning, i think.

yeah, it’s

$ maas $PROFILE maas set-config name=enlist_commissioning value=false

from the CLI. you might still be able to turn it on with MAAS.