Deploy fails to boot

I’ve done dozens of deploys with MAAS over the years, but today an Ubuntu deployment is failing after the deployment seems about done. I’ve tried re-commissioning and re-deploying a few times, but after it appears to finish installing the OS, it reboots and the following shows on the console:

I’m not sure how to attach the installation logs here (it’s huge), but the last line of the log says this:

curtin: Installation finished.

The MAAS dashboard says this:


Any thoughts?

I went ahead and tried doing a network install over IPMI using virtual media (Ubuntu 18 mini.iso) and it looked like a successful install as well, but on first boot, I get this:

Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key

I see that this server has a newer BIOS version than previous servers I deployed. My theory is that the BIOS update broke booting from NVMe drives as it was working previously. I’ve got a support case open with Supermicro.

Supermicro support is suggesting I switch the boot mode in BIOS to UEFI only and then install Ubuntu in “UEFI mode”. I’m trying to get clarification on what they mean by “UEFI mode”… is this something I would even be able to do via a MAAS deployment? After making the switch in BIOS, I tried re-commissioning and re-deploying via MAAS (hoping that MAAS would just detect that Ubuntu needs to be configured to boot via UEFI), but it didn’t work. Ubuntu does not show up as a UEFI boot option in BIOS.

Hi @spockdude

Is this your same issue?

Hi @roota

Thanks for your reply. That does look like the same issue, but the “NVMe firmware source” option does not exist in my BIOS.

This is a Supermicro B2SC1-CPU blade server running the latest 1.5b AMI BIOS. I’ve actually installed Ubuntu using MAAS on several of these blades, but this is the first one that has the updated BIOS. I’m beginning to wonder if I need to revert the BIOS to an earlier version.

I’m continuing this conversation here:

Can MAAS be used to deploy Ubuntu in UEFI boot mode? - Users - Canonical MAAS | Discourse