Allow disabling NTP services

Managing NTP services on a MAAS node via charms is currently not really possible.
If MAAS is deployed from a deb package, the NTP charm and MAAS itself will fight over the control of /etc/chrony/chrony.conf; if MAAS is deployed via the snap the situation will be even worse, as a second chrony binary is bundled in the snap, which will lead to unpredictable results in conjunction to the chrony deb the charm will install and configure.

It would be very useful if there was a way to configure MAAS to not handle NTP services at all. At that point the NTP charm could be made MAAS-aware and have it automate taking over NTP managing duties.

Hi @aleri! So you should be able to disable NTP in MAAS. If you go to the Settings tab, under the Network category, there an NTP section, clicking on that will update the page with a checkbox to “use external NTP only” which will stop MAAS from running its chrony. See the attached screenshot

Hi @cgrabowski.
I tried to verify this behavior.
I managed to find this settings option, but it doesn’t seem to be working for me:

dasm@lmb-nfvi-az1-sv-inf-01:~$ sudo ps -ef | grep chrony
root     18420 47216  0 Jun15 ?        00:01:00 /snap/maas/12555/usr/sbin/chronyd -u root -d -f /var/snap/maas/12555/etc/chrony/chrony.conf

When I compared chrony.conf files, there was no difference.

Am I doing something wrong?


Hey @cgrabowski. That checkbox won’t disable the chrony server running on the host, it’ll change who’s using who as a time source.

I’m posting this to revive this feature request since I believe it’s still on.