Add support for Raspberry Pi 4s

I was poking around at getting Raspberry Pi 4s to PXE boot with MAAS and ran into some issues. I filed a bug report here:

All the ingredients seem to be there:

  • Pi 4s support POE with a simple hat.
  • Unifi POE switch allows MAAS to control power (I was writing a driver for this)
  • Pi 4s support PXE booting

I was able to get some of the booting to work, but it sounds like the detection work still needs to be done. It would be nice if MAAS would ship the Ubuntu Pi amd64+raspi images as well.

5 Likes

@joestump, we tried Pi in the last few months; don’t remember the issue, but there’s something about the way they pxe-boot that makes this difficult for MAAS to support. i’ll check with the guy that tried that and see if i can get you some answers.

@joestump, it’s not in our roadmap right now; we’ve played with it and there are some serious technical issues that we can’t resolve easily on the MAAS side. I’ll leave this open as a feature request.

My experience here reflects @billwear’s sentiments - Pi4 is barely stable in it’s initial offering of pxeboot and requires some heavy lifting to get it right. This should be addressed by the foundation, and when it does, Pi4 should ‘just work’.

A happy related story here is I find that a Pi4 (4GB) is absolutely perfect for running MAAS on, and have several of them running a reasonably complex MAAS-managed infra, with the additional benefit of using another OSS project (PiKVM) to add full IPMI control to commodity hardware.

3 Likes

I’ve also struggled to get my Raspberry Pi 4 to PXE boot with MAAS and my feeling is same as @billwear. For the records, after some quick (and dirty) changes in the MAAS code I was able to boot a focal kernel (32-bits) using the first stage bootloader on EEPROM. More info here: Provisioning of Raspberry Pi 4 with MAAS