We already have a DNS server ... can we still use MAAS?

Hello,

We have been building systems by PXE boot and USB keys for years. We run our own DNS, NTP &c. Can we get MAAS running if it doesn’t control DNS? We are presently using dnsmasq.

Thanks,
-danny

I ran a non-MAAS DNS for several years, but it never quite worked for me. I find that the MAAS cli lets me do the DNS changes that I used to do by hand, so I’m okay with that.

Giving MAAS a subdomain to manage might work for you.

1 Like

Thank you, lloyd.

We’re setting up a new datacenter. Many machines will be rebuilt, and other machines we’re looking to just move over, with a new name/IP. I’ll experiment today with trying MAAS for the first time for new machine builds, and whether it will be appropriate to our needs for “importing” machines that we do not wish to rebuild.

Do folks typically let MAAS run the whole show and let MAAS manage DNS for non-MAAS hardware, or just set up a MAAS subdomain over to the side? My feeling is if MAAS is going to run a DHCP server then we shuold consider going all in.

Hi,

If it isn’t too late, I stumbled upon a (similar) issue. I am also running a DNS server, on the same machine as maas rack+region.

I use CoreDNS.

It seems that the packaged BIND server will listen on all interfaces on port 53, as long as the port is available.

There is an option within the fabric-x configuration, “Provide DNS on this fabric”. This doesn’t seem to affect whether BIND listens on that interface.

I needed to modify the BIND server included in MAAS to only listen on the cluster-local interface.

There are possibilities in modifying the generated BIND configs (under/var). I did this by modifying named.conf.options (or you could do the same in named.conf, or any of the parsed configuration files).

I added thelisten-on {<MAAS DNS IP>;}; directive, to make (MAAS) BIND listen only on the interface that. It then gets complicated - as a very complicated.

The solution I am currently using:

Stop the MAAS service via:

sudo snap stop maas.supervisor

Start your custom DNS server

restart MAAS

sudo snap start maas.supervisor