VM host does not support composability although /dev/kvm exists + "Error: An architecture is required" in GUI

Hi, I am trying to create VM in MAAS following this tutorial https://github.com/antongisli/maas-baremetal-k8s-tutorial/blob/main/maas-setup.sh

I made sure virtualisation was activated in my bios and kvm-ok is returning:

INFO: /dev/kvm exists
KVM acceleration can be used

but when I run:

# add a VM for the juju controller with minimal memory
maas admin vm-host compose $VM_HOST_ID cores=8 memory=2048 architecture="amd64/generic" \
 storage="main:16(pool1)" hostname="juju-controller"
# get the system-id and tag the machine with "juju-controller"
export JUJU_SYSID=$(maas admin machines read | jq  '.[]
| select(."hostname"=="juju-controller")
| .["system_id"]' | tr -d '"')
maas admin tag update-nodes "juju-controller" add=$JUJU_SYSID

I got:

VM host does not support composability.
Machine-readable output follows:
    "added": 0,
    "removed": 0

I tried to compose a VM from the GUI, and I can see the error: “Error: An architecture is required”

Did I forgot to configure something?

which version of LXD do you have?

❯ lxd --version

and MAAS 3.1.0

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

@lhoupert, apologies for letting this one sit so long. i’ve seen this problem before, and it was related to a bug, but in an older Beta version. can you get me this kind of info? you don’t really have to file a bug just yet, but more info is needed to figure this out, i think.

1 Like