Unable to install LXD during bootstrap

I am looking to setup Maas on a virtual machine, this vm, is my region controller. I have followed the bootstrap-maas setup guide to a tee, even the ones that come before it.

I hit a bump when Activity 4 came along. After many retries, restarts, resets, wipes, refreshes, I could not get it to work. I also tried following the ‘how to setup lxd’ doc, that also didn’t work. No matter what combination of yes/no questions I tried when first setting it up.

If I said ‘Yes’ to connect to a maas server, the error was “Could not find hostname” I tried many different hostnames to see

Anything regarding the bridge, using an existing one, resulted in an error about DHCP and DNS exiting prematurely, and giving a different IP in the error message each time.

I am able to access the Web UI, but after clicking around I couldn’t find/do anything that may help.

Hi @tmiller91and welcome to the community :slight_smile:

First of all, have you tried to install lxd first and check if it works properly? What hypervisor are you using for your VM?

Hi @r00ta, thanks for the response!

I have tried that already, and to no avail. As for which Hypervisor, I’m not sure I’m using any - but I am not the one who configured the region controller. When I go to mess with it, like attempt to initialize lxd, I use MobaXTerm to SSH to the vm.

So it sounds like the problem is on LXD side.

I’d suggest you to ask on their discourse how to fix your LXD installation problem (adding some more context/stacktrace/info abour your setup).

After you manage to install LXD successfully, the integration with MAAS should work without problems.

I’m closing this topic but feel free to reopen in case you have any related update!


Just a heads up that the LXD forum is here nowadays:

1 Like