[solved] Nodes calling for localhost:8000

I have a strange thing happening. When I attempt to “Deploy” an Ubuntu 18.04 and watch the rsyslog messages I eventually hit this curious place where it tries to pull debian packages from localhost:8000. This would work from the MaaS server with squid running on port 8000… and caching of packages, however, the logs indicate that it’s trying to pull from the on-demand node.

This results in a failed deployment. Any hints?

Mar 15 21:09:43 good-40 cloud-init[1518]: Stdout: Err:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Mar 15 21:09:43 good-40 cloud-init[1518]:           Could not connect to localhost:8000 ( - connect (111: Connection refused)
Mar 15 21:09:43 good-40 cloud-init[1518]:         Err:2 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Mar 15 21:09:43 good-40 cloud-init[1518]:           Unable to connect to localhost:8000:


Try to change the localhost to the maas IP with this command—> sudo dpkg-reconfigure maas-rack-controller and here too --> sudo dpkg-reconfigure maas-region-controller.
Look like is not find thing the maas hope that helps.


That worked brilliantly. I was trying to find that setting and it never occurred to me to look in the deb package.

Thank you. I am moving on to finding a way to run RHEL and also finding a way to get saltstack running on these instances.

I’m glad it worked, if you want to make manual changes here’s the path /etc/maas/regiond.conf and /etc/maas/rackd.conf.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.