[solved] KVMs added won't boot


#1

I tried to add the VMs by spinning them up manually and seeing them appear in Machines or by using a Pod. Neither method worked.

After seeing the machines appear in Machines, I did go to Configuration and set the Power to virsh. I was able to power up the machine from the UI.

Still - if I had VNC console attached - every time I would see the dreaded message that no bootable hard drives are found.

I looked for meaningful logs, but couldn’t find anything.


#2

Did you configure MAAS to provide DHCP on the virtual bridge?


#3

I did it for the subnet, like in the example in the image below.

I am not sure if I did something special for the virtual bridge. Do you mean the bridge interface on the KVM host? If so - I am not sure I know how to do that.


#4

I recommend on going through the tutorial on how to set up MAAS with KVM Pods. That will get you up and running the fastest.


#5

@blake-rouse - thanks for the response. As I said in my original question - I did try that too. I will post screenshots later.


#6

Yes, you’ve to configure the br on each KVM node.

sudo apt install bridge-utils

Edit /etc/network/interface:

$: sudo cp /etc/network/interfaces /etc/network/interfaces.bck 
$: sudo nano /etc/network/interfaces

If you want to assign a static IP to br0 the file should be something like that:

network:
   version: 2
   renderer: networkd
   ethernets:
     eno2:
       dhcp4: no
       dhcp6: no

   bridges:
     br0:
       interfaces: [eno2]
       dhcp4: no
       dhcp6: no
       addresses: [10.20.81.2/24]
       gateway4: 10.20.81.254
       nameservers:
         addresses: [10.20.81.1]
       parameters:
         stp: false

Save and close the file, then run that to make the netwplan active.

$: sudo netplan try 
$: sudo netplan apply

#7

Hi, all.

I think all this was already done… The thing is - when I start the VM (or provision them through the POD) they do come up, they get installed, and then it is only after they get rebooted that they enter this state

Tomorrow I may just blow it all away and start from scratch…


#8

Hi, everyone. Just to close the loop on this - I had to remove the ‘default’ interface from the virsh configuration. Even though I was specifying br0, it somehow wasn’t working until ‘default’ was removed.