[Solved] Install via Snap don't have log in /var/log/maas


#1

log it’s not available in either /var/log/maas or snap logs maas.

check snap supervisord config (https://github.com/maas/maas/blob/master/snap/local/conf/supervisord.conf.templat), It appears under ENV_SNAP_COMMONs/log, will logs in that dircotry ever be rotated ?

I think all the logs should be ship to /var/log/maas, as the documentation said so.


#2

Hi there,

The MAAS snap is a devmode snap, which means it is still not production ready.

That said, snaps cannot normally access the root filesystem (unless probably classic snaps). Since MAAS is not a classic snap, then it doesn’t access the root filesystem, hence, the snap won’t log to /var/log/maas. MAAS snap logs in /var/snap/maas/common/ as this is the common directory for snaps despite of revisions. Please refer to https://forum.snapcraft.io/t/environment-variables/7983 for more information.

That said, please keep in mind while the documentation applies mostly shows usage of MAAS itself (regardless of the delivery method), there are still sections which are focused on using Ubuntu from debian packages. Once the snap becomes the official path to delivering MAAS, the documentation will be updated accordingly.

If you would like to contribute with the documentation and help update some sections, it is currently located at https://github.com/CanonicalLtd/maas-docs.

Thank you!


#3

Thanks, I’m new to snap, didn’t know that --devmode is not production ready (there is also a stable flag)

currently the doc listed four different ways of installation, snap looks like the simplest one.

Would be better to document which way is prefered and production ready.