[solved] Connecting MAAS to VMWare Workstation machines


#1

I’m trying to connect my MAAS version: 2.4.2 to my VMWare Workstation 15.0 so that it will retrieve the machines from VMWare Workstation. I have read earlier questions and answers and saw that the Workstation machines need to be in the ‘Shared Folder’ so I did that. I also enabled sharing in VMWare Workstation. I checked my firewall and network connection. I am able to telnet to my Workstation machine on port 443 and I get a connection, but when I try to add the “chassis” in MAAS it doesn’t give me any response. When I try to edit the power configuration of one of the existing machines and add my credentials it gives me an SSL error:

Can somebody point me in the right direction?


#2

Thanks for giving MAAS a try! We don’t regularly test with the VMware power driver, so I’m not certain this will work - but try setting the VMware API Protocol field to https+unverified. This will cause MAAS to attempt to override the default behavior of the Python API for VMware of requiring the certificate to be trusted by the system.

Alternatively, you could add the (self-signed, I’m assuming) certificate for your VMware setup to the trust store so that your SSL/TLS enabled applications will trust connections to this VMware host by default.


#3

Thanks! It worked. I can’t believe it. I already tried adding the SSL certificate myself and I also tried to use https+unverified with the CLI command I found somewhere. But that both didn’t work. With the CLI command I always got ‘Succes’ and ‘Asking MAAS01 to add chassis on 192.168.1.100’ but it never showed up. I never tried to just set the protocol in the GUI. Thanks a lot!