[solved] Boot loop with 18.04

Hi, I manage a cluster using MAAS. I’m starting to upgrade the nodes from 14.04 to 18.04, and some nodes are getting stuck in a boot loop with 18.04. Specifically, when the node gets to:

Loading ubuntu/amd64/generic/bionic/daily/boot-initrd… ok

The node reboots immediately. This repeats once it reboots. Here are some key details:

  1. This occurs during Commissioning using 18.04. I can get Commissioning to work by switching to 16.04. However, I get the same problem when I go to Deploy 18.04.

  2. The issue occurs every time with a subset of nodes. However, other nodes with identical hardware do not have this problem.

Could this be related to the fact that I had a messy upgrade of my MAAS server from 14.04 to 16.04. Is there a good way to install a new MAAS server from scratch and point the nodes to it?

Sorry for a newbie question, but I’ve lost several days trying to debug this issue on my own.

Problem solved: when I commissioned some nodes, I decided to ‘remove’ the second NIC from the MAAS list of interfaces. That really screwed up the underlying hardware - the underlying Supermicro BMC reported it only had 1 physical NIC. For some reason, 16.04 (Xenial) did not complain, but when I booted 18.04 (Bionic), it got into a reboot loop each time it loaded the initial ramdisk (boot-initrd).

Seems like there is an upstream problem with Bionic, though it seems like an edge case.

1 Like

I have same problem and I don’t understand exact reason for this, I didn’t do anything with interfaces in node configuration, but it still stuck in boot loop in ubuntu 18.04 (and works fine in 16.04). Can you add some details for this?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.