Snap install 2.9/stable doesn't exist? Only candidate exists?

Reading through docs and says to install via snap install --classic --channel=2.9/stable , however, only that candidate is available? Am I missing something?

Hi @dperkunas!

Seems you may have got things a little confused, since that snap-id is not MAAS but Juju.

$ what-snap e2CPHpB1fUxcKtCyJTsm5t3hN9axJ0yj
e2CPHpB1fUxcKtCyJTsm5t3hN9axJ0yj: juju

I think they’re still working through RC of their 2.9 release, but you should join them at https://discourse.charmhub.io/ and ask there.