Server stuck at boot when I set /var on different disk


#1

Hi everyone,

I use to install my servers using raid 1 over 2 SSD for root partition and /boot, it works fine and I use WebUI storage layout at the moment.
However once I want to set my /var on an other disk I am not able to boot after installation :
37

Here is the storage layout :


I’ve tried on 3 differents servers with the same result, for all of them I’ve set BIOS boot order correclty and I’ve also installed one manually with ISO and it worked fine.
So far I have to remove my 3rd disk from storage layout, do the install and then mount the /var on other disk once it’s installed…

Do you have any idea ?
Thank you !
Ludwig


#2

Hi Ludwig,

I can spot any error that would prevent this from booting. Can you provide some more more information about your setup?

  • Your MAAS version?
  • The exact storage layout, so that it’s clear how md0 and vg00 is constructed

#3

Hello Bjornt,

The actual machine has been installed since but I’ve reproduced the storage layout on different one :

And I’m using version 2.5.0 ! Thank you for looking at it :slight_smile:

Ludwig

UPDATE :
After the screenshot I removed the mounted /var on sda1 partition because I don’t need it on this server, so it was just sda left like that no being used. When I clicked on Deploy the WebUI reselect by itself the sda as boot disk (while it was not used at all) and the deployment started… and my server was stuck at boot again.
I ran a script to wipe beginning of my 3 disks, then I totally removed the 3rd disk from storage layout and at this moment the deployment and boot went well.

UPDATE 2 :
If I wipe 3rd disk and don’t touch it in storage layout I can actually let it here and MaaS is not installing anything on it => when the deployment starts MaaS does not select it at boot :


The issue only happens when I select my 3rd disk as /var one time and then removed it without wiping anything. It is like at this moment MaaS already wrote something on disk or keep trace of this setting.