Release of ubuntu-core-22 machine is not working

Hi All,

In the past, I used MAAS to setup ubuntu-core-22 on a supermicro server. Everything worked fine as expected. Now I want to install ubuntu-server image in the server and triggered release from MAAS enabling disk erase option.

But after some time, server ended up rebooting back into ubuntu-core-22 and MAAS is showing disk erase state for ever.


Is there a way to resolve this issue ?

Well in the case of releasing a machine running with ubuntu-server i havent found any issue. Once released I am able to even deploy the new OS version on it.

But If I am trying to release a machine running with ubuntu-core-22 I am not able to release it. Any pointers or troubleshooting steps would be of great help. Currently logs for the machine is showing nothing which shows the reason for it.

Without additional information I’d say your machine is booting from the disk instead from pxe. I’d check the boot order of the machine, or anyways I would check what happens to the machine (on its screen) when it is released with the erase disk option flagged

Hi @r00ta

Yes, the moment I trigger RELEASE from MAAS UI, server is going for a reboot and then booting up in to disk. Ideally it should reboot into ephemeral mode and wipe out the harddisk right ?

Earlier when I tried the same with ubuntu-server installation, MAAS is able to successfully WIPE the harddisk and end up in NEW stage. This is not the behavior in the case of ubuntu-core. Well if I try to manually boot the server in PXE mode, I am sure it will work. But is this expected way to RELEASE a ubuntu-core server ?

in theory it should work out of the box. I’d suggest to

  1. try to release the machine with the erase disk flag enabled
  2. check on the machine screen what happens
  3. extract the rack logs and paste them somewhere so that I can take a look

Hi @r00ta

I did try RELEASING the machine with erase disk flag enabled and the machine ended up rebooting into harddisk.

Then I checked the bios boot order of the server and it shows boot from harddisk. Well I dont remember manually setting the boot from harddisk as a the default option. When I tried selecting PXE option then it seems to work.

can you please

  1. modify the boot order in your bios/uefi so that pxe is always the first choice
  2. deploy ubuntu core
  3. check in bios/uefi that pxe is still the first entry?

Hi @r00ta

I did try the sequence mentioned by you and looks like it is working fine.

Since I never touched UEFI boot order option in the past where harddisk is the default option. On day 1 it might have failed booting from hardddisk as it does not contain any operating system and ended up booting in PXE where MAAS installed ubuntu-core. Once OS is installed it always ended up rebooting into harddisk.

I followed your steps where

  1. I modified the boot order in UEFI to PXE as a default
  2. Deployed ubuntu-core from MAAS UI successfully
  3. Released the server with disk erase
  4. Re-deployed ubuntu-server from MAAS UI successfully

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.