Raspberry Pi 4B headless boot

After getting Raspberry Pi 4B to work with MAAS images (I don’t use MAAS, just the project’s images, hw-20.04-edge), I have problems with headless boot. If I have the display plugged in, everything goes well. If I unplug it before starting the Pi, it goes offline after downloading the squashfs and doesn’t come back. With a display, it does go offline for only about 15 seconds and then comes back online. No matter what I tried the result is the same. I tried to disable the framebuffer, to use the official power adapter, unplug all the devices.

Any idea how to fix it in software? I ordered dummy HDMI plugs as a workaround but I’d prefer a proper solution.

After further testing, it appears my initial analysis wasn’t accurate. Instead, this appears to be an issue with either tianocore, or pipxe not liking a missing video output. Has nothing to do with MAAS. It can be worked around by using a dummy HDMI plug, or in software, by adding

hdmi_force_hotplug=1
hdmi_safe=1

to config.txt that’s residing on the TFTP server, or wherever else it’s booting from.

It’s difficult for me to know for sure which component in the process is causing this, but the workaround is simple so I don’t particularly care. I’ll report it to pipxe.