PXE failure (Dell PE R440 with Broadcom BCM57414 NetXtreme-E 10G/25G)


I am working on a new OpenStack deployment and noticed that a few nodes had some issues.

When I commission these nodes for the first time PXE work perfectly which leads me to believe that the driver exists. However, when i try and deploy Ubuntu 20.04 (ga & hwe) it does not work.

I snapped a picture of the PXE boot stage.

Notice how the server is answering and the efi file is displayed, but the filesize is 0 bytes.
The servers are configured to PXE boot on the 25G nics and VLAN untagged. I specifically avoid VLAN because i have had issues with that before.

I have two questions regarding this:

  1. How come it works on the first boot? (Commission)
    I cannot successfully commission more than once.
  2. Anyone else tried deploying on these network cards?

Server: Dell PowerEdge R440
Network cars: BCM57414 NetXtreme-E 10Gb/25Gb RDMA Ethernet

Thanks in advance :slight_smile:

I am facing the exact same issue. I reinstalled maas and now I can see the boot resources folder. It has the following file


But the server booting on DHCP seems to be asking for bootx64.efi file. And I could not find this file on the server in boot-resources.

I found this on the rackd.log file:

provisioningserver.rackdservices.tftp: [info] bootx64.efi requested by {CLIENT_IP}

What may I do to correct this error?



  1. I have installed latest version of maas ( maas 2.9) on Ubuntu Server 20.04 LTS.
  2. I initialized maas and selected ubuntu 20.04 as my boot image.
  3. I enabled internal DHCP of maas.
  4. I am trying to boot a Dell R740 server machine over Pxeboot in UEFI mode.
  5. The pxe client is assigned an IP successfully but is unable to download the bootx64.efi file.
  6. I checked in the maas server and could not find the file. Further reading online suggests that this file is supposed to be in boot-resources directory of maas.


I have added the missing bootx64.efi file to the tftp directory. The procedure is as follows:

  1. cd /tmp ( since I ran commands as root)
  2. apt download shim.signed
  3. dpkg -x shim-signed_1.40.4+15+1552672080.a4a1fbe-0ubuntu2_amd64.deb shim ( Extracted to shim directory)
  4. cd /var/lib/maas/boot-resources/snapshot-20210203-051232/ ( This is TFTP directory)
  5. cp /tmp/shim/usr/lib/shim/shimx64.efi.signed bootx64.efi
  6. chown maas: bootx64.efi
  7. chmod 777 bootx64.efi

I hope this solution is useful to someone.



1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.