PXE-E16: No valid offer received


I have deployed a MAAS instance consisting of 1 x Region Controller and 2 x Rack Controllers.
I am trying to PXE boot a VM and provision it using MAAS.

There is an existing DHCP server in this network segment so MAAS DHCP is disabled.

The VM successfully gets an IP Address from the DHCP server but then it does not get a PXE offer.

There is another PXE Deployment server in this network segment however based on various posts, this has been set with a PXE Response Delay to allow MAAS to respond first. I have also tried setting the other PXE server to not respond to any clients. MAAS still doesn’t provide a PXE response.

Thanks for any help you can offer :slight_smile:


I would suggest creating another VLAN that the servers can be connected to, on which MAAS DHCP server can run.

The PXE information that the servers need are in the DHCP response. So if you disable MAAS’ DHCP server and want to use an external one, you have to configure it to send the same information MAAS would. This is how the relevant parts from the DHCP config: Ubuntu Pastebin

Note that in future MAAS versions, that might change.

That’s great thanks for the information.
I have added a second network link to the rack controllers with a different VLAN and setup MAAS DHCP on that network segment.

PXE Boot is working on that segment now for the VM.

Thanks again.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.