PXE boot over trunk port at the switch

Hello Gyus,

There’s anything special I need to do to get a bare-metal to pxe boot a trunk port? I can’t get any machine to pxe boot, would appreciate your help thanks. Not sure if maas supports this type of pxe boot.
MAAS 2.5

Hi Rafise,

this is from documentation:

VLANs
VLANs (Virtual LANs) are a common way to create logically separate networks using the same physical infrastructure.

Managed switches can assign VLANs to each port in either a “tagged” or an “untagged” manner. A VLAN is said to be “untagged” on a particular port when it is the default VLAN for that port, and requires no special configuration in order to access it.

“Tagged” VLANs can also be used with nodes in MAAS. That is, if a switch port is configured such that “tagged” VLAN frames can be sent and received by a MAAS node, that MAAS node can be configured to automatically bring up VLAN interfaces, so that the deployed node can make use of them.

A “Default VLAN” is created for every fabric, to which every new VLAN-aware object in the fabric will be associated with by default (unless specified otherwise).

Concepts and Terms

Thank you, but the problem is that maas cant pxe boot a machine that is on a trunk port even if the maas know about of the vlan in that trunk.

lets say you have a machine on a switch that all ports are trunk how would you commission those machine? maybe I’m doing something wrong .

How are your machine and switch configured?

PXE booting over a trunk port most likely means that the machine will try to PXE boot over the default VLAN that is configured on your switch. As long as you’ve configured MAAS to provide DHCP for that VLAN, it should work.

If you want to PXE boot over a non-default VLAN, you need to configure it in your machine BIOS to tag the PXE traffic with that VLAN. But I would suggest configuring the default VLAN on the switch port, that will make things easier in the end, but either solution is fine.

2 Likes

We pxe over trunk ports all the time we configure the network adaptor bios and provide the vlan we want.

Thanks Guys,
Setup the nic to boot on a specific vlan at the nic bios and I see now booting from maas but it don’t fully finish, it stay at if-config: no response after 2 secs - giving up. any idea what I’m doing wrong?

What about MTU’s ?? Are they set correctly? what about STP/Portfast, are they enabled or disabled?

Hi,

Yes, MTU 1500 at the VLAN tag of the maas STP/Portfast are enabled on the switch.1

Hello Guys,

Cisco switches had a bug after replacement everything stating to work thanks guys for your help. post can be close.

I’m trying to achieve the same thing: PXE boot over VLAN.
I’ve modified the VLAN in the SLOT 2 Port 1 Partition 1 interface in UEFI to tag the packages with the right VLAN tag. I also tried doing the same thing for SLOT 2 Port 2 Partition 1, but that didn’t change things. In MAAS I’ve set the VLAN tag for the network. I now end up with our Dell R430 booting with its 10Gb interface with the following output:


After that we wait a couple of minutes and it jumps to a Grub menu, perhaps remnants from the last deployment.

Ideas why it can’t fetch the Netbook image?