PXE boot failing - Connection Reset

I’ve stoodup KVM+MAAS on a single server with a network bridge and MAAS providing DHCP. When I go to provision a server, PXE starts but but I get a Connection Reset error.

This is running ubuntu 20.04 on the host. I don’t see any errors in any logs that can tell me what’s going on. Any ideas?


yeah, this same error used to drive me nuts. in my case, it was always my misconfiguration, but that doesn’t mean you made a mistake. here are a couple of ideas to try:

  1. walk thru this blog entry and check your KVM setup. it’s probably okay, but worth a quick check.

  2. did you remember to turn off DHCP on the KVM side?

  3. is ufw running?

you probably already caught all these things; if so, just bounce back and we’ll try to go from there.

@mlbiamx, any luck on solving this one?

Hey there. So it turned out the issue was I had a 2.5GB ethernet card on my motherboard that was causing all sorts of issues on my gigabit network. I bought a $15 gigabit PCI ethernet card and voiala!

1 Like

i’m laughing, but only out of recognition. sometimes lower tech does the job, i say, as i work smoothly with my $6 wired mouse that replaced my $300 trackball, that made tea and toast but had a scroll wheel that threw every driver for a loop.

glad you got it solved!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.