Proxmox Vm and MaaS power management type - proxmox

I am trying to provision and deploy a Proxmox vm by MaaS. VM was able to PXE boot by MaaS and able to deploy Ubuntu 20.04 LTS image- with power management type as manual. My Mass Vm is in proxmox itself.

I heard that Maas supports power management type as proxmox and i tried that and it was not working for me. All the permissions are added correctly along with proxmox api key. Is this a limitation of the Proxmox power driver in Maas or do i have to install any proxmox driver that allows maas. -

I am attaching the event log.

Hi @mrk131211

I think the easiest way to troubleshoot this issue would be adding a print statement, and examine what was returned in the response_data

Du you have MAAS installed via snap or deb package?

If it is a deb, simply modify this file:

If it is a snap, then you can check this post:

Check that the token name contains the login realm. I could not get it to work without this despite the documentation saying that it should not be included. I did put in a pull request for this to be amended.
For me it looks like this:

Hii Troyanov,

Thanks for your reply.
The MAAS is installed via snap. I will go through the post you shared.

Thank you.

Hii rodger-duffett,

Thanks for your reply.
I added Just like in the screenshot the you have shared. Still not working! Have you done any configuration changes in MAAS. ?


No configuration changes in MAAS. I am using version 3.4.0~rc1.
The other thing to check is that your API token has the right permissions to your VM tree. It should look something like this:

Also make sure that you have set the right VM Node ID number in the MAAS machine power type config. In my screenshot it is 105 but this must match the VM that you are working with.

1 Like