PfSense + PXE Boot Solution


#1

Hey all, in case someone else ends up here via Google looking for the settings for their PfSense box to handle DHCP but send PXE over to MaaS, I want them to find this. The settings I used on the DHCP Server tab are as follows:

Enable DHCP: On (for obvious reasons)
TFTP Server: xxx.xxx.xxx.100 (your maas controller ip)
Networking Booting: Enabled
Next Server: xxx.xxx.xxx.100 (your maas controller ip again)
Default Bios File Name: bootx64.efi
UEFI 32 bit file name: bootx64.efi
UEFI 64 bit file name: bootx64.efi
Root Path: (I left this empty)

I was having a really hard time getting my machines to talk to the TFTP/PXE server until I added those settings in the DHCP server on the LAN. I hope this helps someone.


#2

Hi Jonathan,

Any chance you can file a bug report in https://bugs.launchpad.net/maas/+filebug and confirm the version of MAAS you are using.

That said, this could actually be related to a firmware issue, but a bug report would better allow for this to be tracked and triaged.

Thanks!