Version 3.5 snap/edge/latest.

I’m having great difficulty when I create the br-ex bridge, according to this link:


With the creation of the Ovs bridge I totally lose contact with LXD and I can’t create more VM. Either UI or CLI, via Juju, it is no longer possible to create VM. Removing the OVS bridge everything goes back to normal, but I can’t go ahead with the Openstack installation.
Juju debug-log return:

controller-0: 20:21:06 ERROR juju.worker.provisioner cannot start instance for machine "3": failed to acquire node: No available machine matches constraints: [('agent_name', ['1225eeb5-f7d5-4f37-8693-27499f2f5f02']), ('tags', ['virtual']), ('zone', ['default'])] (resolved to "tags=virtual zone=default")

Someone is having the same problem, can you help me?

Thank you.

Hi @penacleiton1,

Regarding the juju error it makes sense in case you don’t have any available machine in MAAS.

But in the screenshot there is something wrong of course. What’s the LXD version? If you share your entire setup I might try to reproduce the bug

1 Like

Hello, @r00ta
Thank you for your interest in this problem.

LXD version: 5.17.

You are right that there is no available machine, however, when I delete the OpenVswitch bridge, all machines are available.

The problem only occurs when I use OVS. And this has repercussions on the installation of Openstack, I believe, because it gives an error in the OVN - I think there must be some relationship between them.
Success in your work.
See you soon.

Hello, @r00ta

Please, where and how can I get the information of the complete setup that you request in your message?


ideally provide all the detailed steps to reproduce the issue

1 Like

Hello, @r00ta,

Look, I have 6 physical servers. They are divided into 2 switches. The default IP comes by NIC2, is with dhcp provided by Maas. The deployment of the machines via PXE is done with the option of creating the LXD host of each machine. If I don’t do that, that is, I don’t enable this option, then I can no longer create the host of each server manually, it gives an error, probably from Network - but, I’m not sure. I’ve been opting for LXD and I’ve never tried Libvirt. The physical servers also get IP from the band that comes from NIC 1, without DHCP configuration, and this is where IPMI access is made.

Through MAAS I can create a bridge, but I can’t Bond, this option is always disabled. I also tried to create Open vSwitch bridge through Netplan, but despite everything configured correctly, I could never browse the internet, I came back with the previous Netplan configuration.

I used Juju Controller to install Openstack but I even got to the Network error, OVN, because, I suppose, from Open vSwitch bridge.

This information is sufficient, @r00ta?

Thank you.

Thanks, we’ll investigate in the bug https://bugs.launchpad.net/maas/+bug/2036883 . Closing this topic as we move to LP