No datasource found on node boot


I’ve installed maas latest version with the test-db on a laptop here and I’m testing in my personal lab to get two servers enlisted into maas.
I have an Dell R610 and a Dell R810, for some reason, R810 worked fine, showed up on maas I was able to commission and then deploy.
On the other hand the R610 is not even showing up to be commissioned.
Upon checking the server, this was the message:

I’m not sure what’s up, I tried accessing the the node through SSH but I wasn’t able, maybe the maas didn’t deploy the ssh key idk, but I essentially cannot see any logs besides that one.

I’ve tried using maas on a VM and maas on a physical machine, all servers are on the same subnet.

Since I have no clues as to what is the issue… today I’ll try to reformat the disks on the server maybe it has something to do with the RAID card? also R610 has iDrac express and R810 has idrac enterprise, so I’ll try to swap those out and see if it fixes the issue :thinking:

If by any chances u have any clues here, please let me know.

swapping the idrac didn’t help, trying now different disk configurations from the raid controller :confused:

Different disk configuration also didn’t give anything, also tried switching from UEFI to Boot, nothing…
Trying to see if I manage to update any firmware to see if it helps in anyway.

Anyone has any idea?

So it seems like this error is not impacting MAAS somehow, after days without touching the servers it showed up for commissioning, I rebooted it to check and it’s still showing the same error but now somehow it’s available for commissioning…

Anyone knows how we could debug this to get more info about it? just to prevent future issues I guess

“but I essentially cannot see any logs” - Are you sure you searched everywhere?
Please try find message in log folder:
sudo tail /var/snap/maas/common/log/maas.log
sudo grep -R Fail /var/snap/maas/common/log/|tail -20

“maybe it has something to do with the RAID card”
MaaS does not work if the server has both RAID1 and SD card at the same time

Hey! tks for the answer!

U mean to search those on maas side? or on the node that is failing? My issue is that, for some reason I cannot access the nodes when they have this issue.

My servers have an SD card slot but I’m not using it currently.

In the mean time, I don’t know what is going on but the server showed up when I had a USB stick plugged in for debugging but it didn’t detect any other drives, I removed the machine to try and update the storage to show my drives but now it’s not showing again.

Yes, maas side )

try to turn off the SD card slot directly in the BIOS

I still cannot fully believe… but I found the issue… a super wierdly faulty ethernet cable or patch (haven’t debugged yet the exact point of failure)

I’m not sure if it was the ethernet cable or the patch panel but somewhere somehow… it was getting an IP and connecting nicely, I could even access the iDRAC, it would boot to the iso from MAAS and then it would drop the connection somehow.

How it happened that it worked only for boot and then dropped the connection I still cannot understand at all but I just tried using the cables from R810 and it just worked first try, no issues…

Anyway, thanks for the help :face_with_head_bandage: