New Machine not enlisting

Hey All,

We have a MaaS server at version 2.8.2. This server has been running and upgraded over the years since 2016. However, today I witnesses an issue I’ve never seen before with a brand new server.

My team purchased a new Dell R650 with 2xIntel Ice Lake 8380. The machine has 3 network cards, and is attempting to PXE boot off of a Broadcom Gigabit Ethernet BCM5720. What I see is MaaS give the machine an IP, and start to hand off the kernel but then hang indefinitely with no errors:

Downloading NBP file…
NBP file downloaded successfully.
Fetching Netboot Image
Booting under MAAS direction…

From our server side rackd.log (.234 is the Station IP address):

[info] bootx64.efi requested by 10.118.97.234
[info] grubx64.efi requested by 10.118.97.234
[info] /grub/x86_64-efi/command.lst requested by 10.118.97.234
[info] /grub/x86_64-efi/fs.lst requested by 10.118.97.234
[info] /grub/x86_64-efi/crypto.lst requested by 10.118.97.234
[info] /grub/x86_64-efi/terminal.lst requested by 10.118.97.234
[info] /grub/grub.cfg requested by 10.118.97.234
[info] /grub/grub.cfg-bc:97:e1:80:44:28 requested by 10.118.97.234
[info] /grub/grub.cfg-default-amd64 requested by 10.118.97.234
[info] /images/ubuntu/amd64/ga-20.04/focal/stable/boot-kernel requested by 10.118.97.234
[info] /images/ubuntu/amd64/ga-20.04/focal/stable/boot-initrd requested by 10.118.97.234

Does anybody have any ideas about what to look for? Any help is greatly appreciated.
Thanks

Hi,

Have you solved this? I got the same issue, I was playing with pre-release hardware and it has LOM that uses BCM5720. It stopped after “Booting under MAAS direction”.
At first I thought it might be the BIOS is half-cooked, so I purchased a Dell NIC with BCM5720, that doesn’t work too. Strangely enough on the same hardware NIC with Intel X550 works.

Have you tried on a clean install of maas 2.8.2?
also a good idea to check on the current version of Maas 3.1

At this point your question looks like you have an old MaaS that somehow broke. This is not the same as just a problem in MaaS :smiley:

I’m using maas 3.0, might upgrade to 3.1 soon. My co-worker from another lab have fresh install of maas 3.0 got the same message :frowning:

Does work manually install ubuntu 20.04?

If you talking about manually install ubuntu on the hardware, yes it works ok, the BCM5720 has no problem.

It looks like a bug MaaS

The problem persist.
I’ve deployed a fresh maas 3.1, set the commission os to ubuntu 20.04 hwe-edge (and hwe).
On the target host, I’m using a PCIE NIC with BCM5720.

Stop at the same screen. My rackd log largely similar to OP

I’ve got this resolved today.
After upgraded the BCM5720 firmware to 21.80.9, the machine successfully pxeboot to maas, and the enlistment is now completed!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.