Nameserver configuration on newly comissioned nodes


#1

Hello there, newbie question.

I have my MAAS controller wired up and running 2.5.x and I have a new node that I want to comission. When I do so it spins up and runs its scripts but fails because the node has no access to the interwebs…

when I look in resolv.conf its set to 127.0.0.53

What do I need to fix to make it find the internet?

Thanks

Tom


#2

Hi Tom,

The IP address on resolv.conf is expected, because systemd is what’s managing DNS. So if you do:

systemd-resolve --status

It should show you the DNS server that’s actually using; as such, I don’t think the issue has to do with the internet.

That said, to commission, the machine needs access to the Ubuntu archive, and by default, it uses the MAAS internal proxy to access it. So the issue could be related to do. Is there any chance you can post the following logs:

  • /var/log/maas/rsyslog///messages # from the time it commissions.
  • /var/log/cloud-init*.log : From the commissioning environment on the machine itself.

Also, please check the proxy logs on the controller(s):

  • /var/log/maas/proxy/access.log

#3

Thanks @andreserl

My knowledge of fixing routing issues on Linux boxes extends as far as checking the default gateway and fixing the nameserver line in resolv.conf so I’m easily led astray! :wink:

That said, if I replace 127.0.0.53 with 8.8.8.8 the box can then connect to the internet so my setup on the controller is funky I guess if thats used as a DNS server.

Anyway:

Cloudinit:
http://paste.ubuntu.com/p/njMy5gKh45/
http://paste.ubuntu.com/p/CbdqR6JW9Z/

Rsyslog
http://paste.ubuntu.com/p/ks2qpWjQsf/

Proxy:
http://paste.ubuntu.com/p/gJy2smMDNJ/


#4

@magicaltrout Be sure you have an upstream DNS server set on the MAAS -> Settings -> Network Services page. Without an upstream DNS server set commissioning machines will not be able to reach the internet.

Setting 8.8.8.8 in that setting should allow your environment to work.


#5

Hey @blake-rouse thanks for the reply and apologies for the severe delay in response!

I have 8.8.8.8 8.8.4.4 set in the Network Services DNS settings. Which I had checked and its still the same. On the MAAS controller node the resolv conf is also set to 127.0.0.53 but as you rightly point out, can’t reach the interweb without manually changing that to 8.8.8.8…

I feel like i’m missing something obvious!


#6

Sorry should also say, ping google.com says Temporary failure in name resolution. So its sad about DNS lookups… which is ironic seeing how its supposed to control DNS…


#7

Alrighty, so it seems I needed to add some nameservers to my netplan on the region server.

I’m not sure why they weren’t there at install time, but adding them in makes the DNS server happy clearly cause it can then talk to the internet…