Missing power_parameters in the MAAS CLI docs

maas $MAAS_USER machines create architecture=amd64 \
  power_type=manual mac_addresses=52:54:00:00:00:01

This command doesn’t work on MAAS 3.4/stable. It just returns a table header line.

│ Hostname │ Power │ Status │ Owner │ Arch │ #CPUs │ RAM │ Resource pool │ Zone │

Hi @maasuser1 ,

If I run that exact command on 3.4/stable I get

maas $MAAS_USER machines create architecture=amd64   power_type=virsh mac_addresses=52:54:00:00:00:01
{"power_parameters": ["This field is required."]}

having said that, you are missing the power_parameters_power_address and power_parameters_power_id (also power_parameters_power_password if you have a password)

Thanks, R00ta. I was trying to say I ran power_type=manual, but I forgot to change the formatted string before I click “Post”.

btw you are currently using the python-libmaas CLI, not the MAAS cli.

FYI I’ve updated the docs, the changes will be reflected in few days. Thanks for reporting!

OK, It seems that the pythonlib-maas has taken the command maas.

~: which maas

How can I access the genuine maas command without removing the python lib? I depend on the pythonlib-maas for utility scripts synchronising metadata from MAAS to the netbox. Thanks

The problem is that the python-libmaas CLI name clashes with the MAAS CLI name. If you look at your PATH variable, it defines the order. If you change it in the future for whatever reason, your scripts will be messed up as the MAAS CLI might be executed first.

If you installed maas with snap, you can find the CLI at /snap/bin/maas.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.