Manual commission IPMI Power configuration issue

Hello, dear all.
Maybe someone can help us. We’re evaluating MAAS (latest version) and got this problem. When trying to apply Power configuration settings using IPMI option, the GUI provide an error: “Error: Incorrect username. Check BMC configuration and try again.”. If using the IPMITOOLS installed on the same server where MAAS is installed and trying to connect to the same IPMI, it is working well with the same credentials. I was not able to find anything deeper in the logs. We tried all available options in MAAS Power configuration, like Power Driver, Cipher Suite ID and Privilege Level. Always getting the same error. 'Serial and IPMI over LAN" are enabled.

Thank you in advance.

I would start by trying the exact command MAAS uses on that system. That would be

ipmipower -W opensesspriv --driver-type (LAN or LAN_2_0) -u $IPMI_USERNAME -p $IPMI_PASSWORD -k (The IPMI KG key if one is set) -I (IPMI cipher id, 3, 8, 12, or 17, 3 is the default) -l (USER, OPERATOR, or ADMIN) --stat

Where you able to successfully run MAAS enlistment or commissioning?

Thank you for your reply. Actually, I think I found the solution, but not sure I can explain it logically. What I did, its just tried to create another user in IPMI management and not use the default one ‘admin’ (which is super-duper admin. Why this one shouldn’t work?.. :slight_smile: ) and - its worked. The commissioning scripts still failed to do whatever they should do, but at least the Power Management issue was solved.

Will appreciate for any comments about if someone have to explain why its didn’t worked with builtin ‘admin’ user.

1 Like

MAAS 2.9 added support for a number of IPMI options. One of them being the privilege level which is now set to operator. You could try changing that to administrator

@leo345345t, i think you explained it very logically! :slight_smile: did @ltrager’s suggestion for privs help at all?

So, I did my tests and the result is - no matter which privilege I choose, the default built in ADMIN user is not working. If I create a new user, both Operator and Administrator roles are working.