Manage IBM Server X3650 M4 on MAAS


#1

I’ve 4 IBM Server X3650 M4 and I’d like to manage them on my MAAS server but I don’t know how to set on MAAS their Power type (BMC).

What you see below is what I have on MAAS after the first boot, but if I try to run the commission the nodes not start and their status remain on New.

Someone knows how I’ve to procedure? thanks.


#2

When a host is booted on a network which MAAS controls the machine goes into enlistment which gathers basic information about the system. If an IPMI, HP Moonshot, or Facebook Wedge BMC is detected MAAS creates its own user to interact with the BMC. It appears MAAS is detecting that the IBM Server X3650 M4 is using an IPMI BMC and has configured it with a MAAS username and password.

A rack controller must be on the same network as the BMC. You can test this by SSHing into the machine running the rack and executing the following command
$ ipmipower -s -D LAN_2_0 -h 192.168.70.125 -u maas -p l005vVhVl2

The MAAS logs may also provide more information, they are available in /var/log/maas


#3

MAAS Region and Rack controller are installed on another Server and I’d like to use 4 IBM Server X3650 M4 as node to install Openstack, both of them are on the same network. of MAAS server.
My issue is after that the node is enlistmented on MAAS, the node don’t start after I run the commission. it rest down.


#4

Did the ipmipower command work? What do the MAAS logs show when you try to power on a machine? I suspect the BMC of your server is on a network MAAS does not have access to.


#5

what is the command to run ipmi from MAAS?


#6

ipmipower -s -D LAN_2_0 -h 192.168.70.125 -u maas -p l005vVhVl2


#7

it’s not present, I’ve to install that via

sudo apt install freeipmi-tools


#8

Ricardo- make sure the IPMI is enable in the IMM setting (bios), reboot the system (M3650 M4) and make sure the IMPI is enable in the IMM configuration, that can cause the maas not to power on/off the server. leet me know thanks


#9

This is the result after I’ve made some sets on its Bios

$: ipmipower -s -D LAN_2_0 -h 10.20.81.2 -u maas -p LLtT3tXN782qFN
10.20.81.2: on

but I’m not sure all of that are correctly right, now on MAAS the node is in ready status. Soon I’ll post the screens of the bios and we can see if all sets are right.


#10

From the screenshots you’ve posted it appears that power management should be working correctly. I would try deploying an operating system or commissioning again to verify.


#11

now my Q is:
The lab has to have 3 networks: one for IPMI management; one for the physical interface (eno2) and one for second one (eno3). Or IPMI and eno2 can be have the same IP address or network?


#12

MAAS only needs to be directly connected or routed to the IPMI network. In other words, you can put a single rack controller in the IPMI management network and MAAS will be able to power manage your machines.


#13

So, in my Maas I’d have only an IPMI network configurated for the MNGT, and an physical interface to dedicate to nodes, right?

like that:

I’ve removed all interfaces and left the eno3 where is actived the DHCP.


#14

here is what you asked me

Ubuntu is deployed on IBM system M3650 M4 via Maas. To use a connection via ssh, do you know which are the credentials? thanks


#15

these are the screens of the BIOS to set IPMI on IBM system x3650 M4


#16

Ric,

Switch the shared option to dedicated and try to commission the box, everything else looks fine to me. Also disable the ip6 let us know thanks


#17

I’ve done that, but I’ve optained this error

Error: Connection timed out while performing power action. Check BMC configuration and connectivity and try again.


#18

Ok Try this 1-delete the node, 2- poweron the node let come back to the maas under machines 3- commission the node. let us know thanks.


#19

the same error…

my opinion: maybe there is a set to make on the Bios to indicate on which interface we want actived the IMM??? in this way the dedicated option is correct, if it is shared I think that the IMM address IP can be reached from each physical interface. no?
back to the IBM 3650M4 I’ve the following network interfaces:
1/IMM
2
3
4
IMM2
I want to change the cable to IMM2 and check


#20

the answer is that:

A dedicated systems-management network port might not be available on your server. If your hardware does not have a dedicated network port, the shared setting is the only IMM2 setting available. On the Network Configuration screen, select Dedicated (if applicable) or Shared in the Network Interface Port field.

have a look here:

my servers don’t have a dedicated interface.