machines keep failing deployment due too FileNotFoundError: [Errno 2] No such file or directory: '/dev/disk/by-id

Maas machines keep failing deployment with error FileNotFoundError: [Errno 2] No such file or directory: ‘/dev/disk/by-id’

my setup is as follows
host machine is windows 10 and i am using virtualbox to run a guest vm of ubuntu desktop 18.04.4 LTS.
now in my ubuntu desktop guest virtual machine i have installed qemu/kvm/libvirt to virtualize two guest machines that will be deployed with maas. below i am creating an outline of my nested virtualized environment

-windows 10 running virtualbox
-ubuntu desktop 18.04.4 LTS (qemu/kvm/libvirt)
- guest ubuntu server 18.04.3 LTS running maas-region-controller and maas-rack-controller
- 2 guest vm’s to pxe boot from maas that are created from virtual machine manager in my ubuntu
desktop VM

for my 2 guest virtual machines i am using the virsh power-parameters which maas has control of. maas is able to power them on, commission, and enter them into rescue mode and exit rescue mode. these features also work from the maas cli.

my problem is that every time i deploy these hosts they keep failing deployment. I upgraded from maas 2.4.2 to 2.8.1 as well and it did not resolve this problem, had the same error from both versions of maas. can someone please help as i am tasked with creating a virtualized devops environment. are company uses maas in our production environment.

devsync happy - path /dev/vda now exists return volume path /dev/vda install_devices: [’/dev/vda’] Generating grub debconf_selections for devices=[’/dev/vda’] uefi=False finish: cmd-install/stage-curthooks/builtin/cmd-curthooks/install-grub: FAIL: installing grub to target devices finish: cmd-install/stage-curthooks/builtin/cmd-curthooks/configuring-bootloader: FAIL: configuring target system bootloader finish: cmd-install/stage-curthooks/builtin/cmd-curthooks: FAIL: curtin command curthooks Traceback (most recent call last): File “/curtin/curtin/commands/main.py”, line 202, in main ret = args.func(args) File “/curtin/curtin/commands/curthooks.py”, line 1770, in curthooks builtin_curthooks(cfg, target, state) File “/curtin/curtin/commands/curthooks.py”, line 1736, in builtin_curthooks setup_grub(cfg, target, osfamily=osfamily) File “/curtin/curtin/commands/curthooks.py”, line 689, in setup_grub configure_grub_debconf(instdevs, target, uefi_bootable) File “/curtin/curtin/commands/curthooks.py”, line 509, in configure_grub_debconf link = block.disk_to_byid_path(dev) File “/curtin/curtin/block/init.py”, line 869, in disk_to_byid_path mapping = get_dev_disk_byid() File “/curtin/curtin/block/init.py”, line 861, in get_dev_disk_byid return _get_dev_disk_by_prefix(’/dev/disk/by-id’) File “/curtin/curtin/block/init.py”, line 846, in _get_dev_disk_by_prefix for path in os.listdir(prefix)] FileNotFoundError: [Errno 2] No such file or directory: ‘/dev/disk/by-id’ [Errno 2] No such file or directory: ‘/dev/disk/by-id’ Stderr: ‘’

Have you tried using Rescue Mode to then SSH in and poke around? What image/distro are you trying to deploy?

Nested VMs is a tricky situation, and requires careful configuration.

So this was reported as bug and has been Fixed/Triaged - https://bugs.launchpad.net/maas/2.8/+bug/1876258

How can I get a MAAS Version at 2.8 that contains the fix?

can you confirm what version you’re using now? i think it’s 2.4.1, but i’m not sure.

I use a fresh install of ubuntu 20.04 (updated/upgraded) and I have tried to deploy ubuntu 20.04 and 20.10 via MAAS.

The maas install is also a fresh snap install region+rack controller.
The version info in the footer is: MAAS version: 2.8.2 (8577-g.a3e674063)