Machines cannot use rack NTPs

Hello Everyone,

I hope your doing fine.

After a fresh MaaS snap 3.4 Beta 3 install, region+rack, I cannot telnet port 123 for NTP from nowhere even if :

ps -ZyAlf | grep -i -e ntp -e chrony
        -                               S root         969     703  0  80   0  4004  2656 -      16:37 ?        00:00:00 /snap/maas/x1/usr/sbin/chronyd -u root -d -f /var/snap/maas/x1/etc/chrony/chrony.conf
sudo tail -f /var/snap/maas/common/log/chrony.log
2023-09-26T16:37:51Z chronyd version 4.2 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SIGND +ASYNCDNS +NTS +SECHASH +IPV6 -DEBUG)
2023-09-26T16:37:51Z Could not open keyfile /var/snap/maas/current/etc/chrony/chrony.keys
2023-09-26T16:37:51Z Running with root privileges
2023-09-26T16:37:51Z Frequency 0.000 +/- 1000000.000 ppm read from /var/snap/maas/common/chrony/chrony.drift

cat /var/snap/maas/x1/etc/chrony/chrony.conf
# Welcome to the chrony configuration file. See chrony.conf(5) for more
# information about usuable directives.

# Use servers from the NTP Pool Project. Approved by Ubuntu Technical Board
# on 2011-02-08 (LP: #104525). See for
# more information.
# pool iburst  # Disabled by MAAS.
# pool iburst  # Disabled by MAAS.
# pool iburst  # Disabled by MAAS.
# pool iburst  # Disabled by MAAS.

# Use Ubuntu's ntp server as a fallback.
# pool  # Disabled by MAAS.

# This directive specify the location of the file containing ID/key pairs for
# NTP authentication.
keyfile /var/snap/maas/current/etc/chrony/chrony.keys

# This directive specify the file into which chronyd will store the rate
# information.
driftfile /var/snap/maas/common/chrony/chrony.drift

# Uncomment the following line to turn logging on.
#log tracking measurements statistics

# Log files location.
logdir /var/snap/maas/common/log/chrony

pidfile /var/snap/maas/current/run/
dumpdir /var/snap/maas/current/run
bindcmdaddress /var/snap/maas/current/run/chronyd.sock

# Stop bad estimates upsetting machine clock.
maxupdateskew 100.0

# This directive enables kernel synchronisation (every 11 minutes) of the
# real-time clock. Note that it can’t be used along with the 'rtcfile' directive.

# Step the system clock instead of slewing it if the adjustment is larger than
# one second, but only in the first three clock updates.
makestep 1 3

include /var/snap/maas/x1/etc/chrony/maas.conf

cat /var/snap/maas/x1/etc/chrony/maas.conf
# MAAS NTP configuration.
hwtimestamp *
local stratum 8 orphan

Any advices on how to debug the issue ?
Thanks in advance,
Best Regards,

Hi @mkl1

I am wondering if by telnet you meant the telnet tool?
IIRC it can be used only for TCP, while NTP is UDP:123

Can you please try with netcat instead?
nc -vz -u $MAAS_IP 123

I tested in a fresh container running 3.3 and 3.4-beta and it seems to work:

❯ nc -vz -u 123
Connection to 123 port [udp/ntp] succeeded!

Year, you’re right, my mistake, I’ll check again with the correct tooling ; - (
Thanks for the example.