MAAS Unable to commision (reuse) old node.

Hello Everyone,


TL,DR: Deployed and destroyed OpenStack 3 times, now unable to commision those same servers. Getting error in the screenshot below. Thanks.

Been struggling with this error for a day. Hoping one of you might seen this before or at least have some idea where to look. Before getting the error I ran commission, deployment and destroy 3 times. All were deploying fine. I was able to use Juju to deploy OpenStack. I was changing configuration and redeploying. However, now I can’t seem to even commision a server. There was no network changes.

My best guess is that I ran out of IPs in the subnet. The reason I think that, is the same 3 servers showing up with different IPs as Observed. Subnet shows 45% full, but all the servers should have been deleted when I ran juju destroy-model openstack. Is there a way to “clean up” subnet? Delete all assigned IPs for both Auto Assigned and DHCP?

Any advice is appreciated.

Do you perhaps have any user created DNS entries?
I’m struggling with a seemingly similar issue where if I delete user created DNS entries, they don’t actually get released, and they ‘consume’ IPs in the subnet