MAAS to apt update

I’m setting up MAAS for our workstations and it’s going great! I’ve deployed a test VM with it. The only thing that doesn’t work is apt.

I can’t perform an apt update. It looks for 172-16-0-0--16.maas-internal and I have no idea where it’s getting it from.

This is the full output:

~# apt update
Err:1 stable InRelease
  Could not resolve '172-16-0-0--16.maas-internal'
Err:2 http://aptly bionic InRelease            
  Could not resolve '172-16-0-0--16.maas-internal'
Err:3 http://aptly bionic-updates InRelease    
  Could not resolve '172-16-0-0--16.maas-internal'
Err:4 http://aptly bionic-security InRelease
  Could not resolve '172-16-0-0--16.maas-internal'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.
W: Failed to fetch http://aptly/dists/bionic/InRelease  Could not resolve '172-16-0-0--16.maas-internal'
W: Failed to fetch http://aptly/dists/bionic-updates/InRelease  Could not resolve '172-16-0-0--16.maas-internal'
W: Failed to fetch http://aptly/dists/bionic-security/InRelease  Could not resolve '172-16-0-0--16.maas-internal'
W: Failed to fetch  Could not resolve '172-16-0-0--16.maas-internal'
W: Some index files failed to download. They have been ignored, or old ones used instead.

This is my /etc/apt/sources.list file:

# Aptly 
deb [trusted=yes arch=amd64] http://aptly/ bionic main universe 
deb [trusted=yes arch=amd64] http://aptly/ bionic-updates main universe
deb [trusted=yes arch=amd64] http://aptly/ bionic-security main universe

I also tried it with the default sources.list but it had the same error.

The /etc/resolv.conf file just points to my DNS server.

No matter what I put in my sources.list file it keeps complaining about 172-16-0-0--16.maas-internal. Why is it looking for 172-16-0-0--16.maas-internal? What is it? Can i go around it? Do I have to setup a new DNS record? How can I have apt working?

Huge thanks ahead!

SOLVED: had to delete /etc/apt/apt.conf.d/90curtin-aptproxy

How do I prevent it in deployments though?

By default, MAAS sets its own proxy for APT for deployed machines (by telling curtin do to that, which results in the APT conf file you pointed out).

If you don’t want to use a proxy, or use a different one, you can change that in MAAS settings, under the “Network” section.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.