MAAS setup with existing/external dhcp

  • I have been trying unsuccessfully to find detailed instructions on how to setup and use MASS with an existing dhcp server.
  • I have installed MAAS and everything looks okay. I am able to connect with the web interface and the MAAS server is able to see the devices in the network.
  • I tried adding the reserved ip range as it says in the instructions under How to configure external DHCP.
  • When I try booting a machine on the network with network boot/pxe boot it says ‘no media found’ and continues on to the rest of the boot process.
  • I would like to be able to use MAAS on these machines but am unsure which direction to go as far as getting it working with my current dhcp
  • My current dhcp server is the basic server created when you setup an edgerouter 12, the router is connected to a switch which is then connected to my client machines and my machine with MAAS installed on it.
  • I would prefer not to have to create vlans.
  • Would prefer not to use a dhcp server other then the one on my router.

How might I get MAAS up and running? Would it be possible with a proxydhcp adding the required rules? Would certain dhcp rules need to be enabled/configured in the router? What needs to be done in the MAAS server?

Hi @robert-datacare!

It seems to me that currently MAAS is not capable of being a PXE-only DHCP server on its own. The instructions you linked describe the way for MAAS to co-exist with other DHCP servers in the network.

We don’t have the official support for external DHCP servers as of now, but you could try configuring your DHCP server the way MAAS does by examining the dhcpd.conf MAAS generates, although it might be tricky. In case you use that approach, you should then disable MAAS DHCP server since it’s no longer needed. This will obviously mean that you might have to reconfigure your server each time you upgrade your MAAS instance.

What would be the default file location of the dhcpd.conf that maas generates?

It’s /var/snap/maas/common/maas/dhcpd.conf for snap installation when DHCP is enabled.

@robert-datacare, did you try @igor-brovtsin’s instructions?

I ended up disabling my router dhcp and using the built in maas dhcp.


that’s probably the “designed-to” solution. that said, we probably need more doc and troubleshooting data (at the very least) around MAAS and DHCP. it’s always DHCP. glad you got something running.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.