MAAS rack can't commission servers


I do have two servers racks in different Data Center . The first rack where the region+rack maas is installed are using the IP subnet and is setup with ip, the second rack where the rack maas is installed has the subnet and the IP is

The problem is that I can not commission any machine . The error that I get is :
At machine :

cloud-init[1472]: request to failed. sleeping 1.: HTTP Error 504: Gateway Time-out
At maas rack :

[error] 116436#116436: *3700 upstream timed out (110: Unknown error) while reading response header from upstream, client:, server: , request: “POST /MAAS/metadata/2012-03-01/ HTTP/1.1”, upstream: “”, host: "

But if I run the command

curl XXX.XXX.XXX.XXX:5248/MAAS/metadata/2012-03-01/


Either at maas rack or at the machine .

I can run the network testing at machine and everything working fine .

Any help ?

Hi there,

MAAS version?

Hi MAAS version 3.3 (1:3.3.7-13246-g.2341ebf5d-0) installed from PPA .

I guess that your rack at 249 is forwarding the requests to the region 20 and for some reasons the region does not reply (maybe it was down, maybe a networking issue in your infra). This is expected to happen.

anything interesting in the .20 regiond logs at that time?

Can you still reproduce the issue on every commissioning operation?

Hi r00ta ,

What I can say about the network configuration :
I can ssh from 249 to 20 and also from 20 to 249 , that was my first test . All network is working because the syslog is working fine .
I could no see nothing at .20 log , any specific file would provide interesting information ?
At the .20 maas rack everything works fine , commission, deploy all good .

Now I figure out something that could be the problem . The connection between two Rack are limited to 1.0MB/s , I guess that can be the cause , right ? tested using a scp download .

We are working to fix that .

yes, this can be definitely a problem!

Keep me posted!

Problem solved , that was really related to network.
I don´t think that was only the poor performance but the traffic was not going correctly also .
Now we have commissioning working ,
Thanks r00ta for the help .

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.