MaaS OS deployment is failing with cloud init error.

Hi ,
I was trying to do Canonical Openstack deployment. I was facing some issue while triggering JUJU controller deployment.
Commission of the node is successful. But "juju bootstrap --constraints tags=juju mymaas maas-controller’ is failing . Even i tried to do OS deployment directly on the node , stil same error. It is failing with "cloud-ini Data source not found " error.

I used “Maas/stable” for MaaS installation. And i was using single nic for Maas node and JUJU controller node.
I even tried with Ubuntu16 and 18 too.

please suggest.

@yrishi555, you’re using 2.8 stable?

I’ve been running into ‘data source not found’ randomly in two different Maas environments for a while now.

I found it’s either related to squid or bind randomly crashing

Things I’ve tried (which sometimes help) Change the proxy config from ‘Don’t use a proxy’ to ‘MAAS built-in’ or the inverse.

On the DNS forwarding, don’t provide any external networks that will be allowed to use MAAS for DNS resolution.

I’m not saying these are solutions but things I’ve tried while screaming profanities at my computer screen. Sometimes they work

1 Like

@dvnt, nice catch, you’ve narrowed it down, that might help us.

computer screens sometimes respond well to profanities, fwiw.

can you tell me more about both of the MAAS environments where you’re seeing this? i may be able to figure out which logs might help us…

@dvnt, could it be related to this? https://bugs.launchpad.net/maas/+bug/1885908

fwiw, I saw a similar failure on an ancient 2.5.0 (7442-gdf68e30a5-0ubuntu1~18.04.1) install. It is intermittent. Restarting maas-rackd/maas-regiond seems to have worked around it for me, but its not clear what the root cause is.

@billwear I’m not convinced it’s a 100% match on the bug string.

To what @dannf says, it is random and sometimes a reboot helps, other times making tiny changes and then reverting them helps.

It’s comparable to sand grains in a watch, sometimes little knocks help the gears to move again while other times smashing it against the table seems to do the trick.

I am seeing this also. I can deploy 18.04, but not 20.04. 20.04 fails with cloud-init Data Source Not Found Exception.

This is the second machine I’ve deployed and the first one deployed successfully using 20.04. They are configured almost identically although verifying the BIOS configs is a pain in the ass. Anyone know of any tools that can dump the BIOS config to a text file? Or did the ubuntu 20 image change in the last 4 days? Where are the images stored?

I added a dynamic reserved range to my MAAS provisioned IPv6 subnet and now UB 20.04 installs

‘data source not found’ indicates that cloud-init is unable to reach MAAS’s metadata server. This is where cloud-init gets SSH keys and user_data. Make sure your machines have access to the MAAS DNS server or disable DNS on the subnet by settings Allow DNS resolution on the subnet to false.

I hope this helps somebody. I faced the same issue, and the problem was very simple.
You must be sure to specify a DNS IP in the Subnet Summary. If you enabled the “Allow DNS resolution” the DNS IP must be yours MaaS Region/Rack servers IP.

1 Like