Maas login 403 forbidden


#1

I have installed the latest MAAS development version and upgraded today to 2.6.0-beta1
However ever since I installed it I cannot perform a maas login.
I have tried many combinations of the server URL. For instance

maas login jhearns http://localhost:5240/MAAS $MAAS_API_KEY

where I am certain the API key is correct. I get returned (403, b’Forbidden’)
I have tried looking in the maas logs and in the http server logs, but nothing is obvious.
Please give me some hints on wher eI could find logging of this request.
The other explanation is a firewall issue. But surely if I can open the web browser on port 5240 fine, and in addition I al running this maas logn on localhost it should be fine.

Clearly this is a simple setting and I will kick myself when an expert kindly enlightens me.
Thankyou


#2

Aaarghh. I think I have the answer - I set an http_proxy in my environment.
The problem is now solved.
I guess this forum has helped - it forced me to think the problem through.


#3

try […] http://localhost:5240/MAAS/ […], I believe there’s an open bug on the matter.


#4

Thankyou. The problem was the http_proxy so I set no_proxy
I agree about the trailing slash also - the documentation might be improved there.