MaaS fails on deployment reboot. MaaS sets gateway to

Hello everyone! I have booted 9 nodes successfully, however the last one wont succeed. When deploying, it fails after reboot due to MaaS not being able to connect to node (node does not respond to ping either). I saw during boot that instead of using default gateway I have setup in MaaS UI, it has set as gateway… Anyone experienced something similar before?

Using a bonded interface (2 NICs) untagged for PXE boot, and then 3 vlans tagged on the bond in addition

@serverant, what version of MAAS are you using? have you checked to see if any log data is available to help?

1 Like

MaaS version 2.9.1 (9153-g.66318f531)

Checked logs, seems that everything works as it should from MaaS´s side until the node reboots and MaaS just waits for reconnecting to node, and then time outs with “Script - gateway-connectivity on bond0.10 failed to apply custom network configuration”

And as I mentioned, I have setup gateway in MaaS, so I found it strange that the node shows gateway as seen on screenshot above.

Here is also image from config of gateway:

1 Like

@serverant, thanks. i will have to ponder this.

Here you can see our network config. Its identical on the other 9 servers we deployed, and then it worked. 2 of them being the same server type with the same NICs…

Now another node that worked, and we redeployed, suddently stops responding. MaaS shows as Powering On, while the node is on login screen for Ubuntu…

Im considering reinstalling MaaS again, however this has already happened once before…

@serverant, a bit late getting back to this, but did you ever get it solved?