Maas failed deployment but the installation was finished


I am trying to deploy a machine that is located in VMWare with Ubuntu 20.04 (also tried with Ubuntu 22.04 - and it did not work).
It tells me:

Marking node failed - Installation failed (refer to the installation log for more information).|
Node installation failure - ‘cloudinit’ running modules for final|

I can see in the installation output that it was finished. When I go to the logs it says that failed with 2 errors (although it does not say which ones).

Any idea on why this might be happening?

@kcpf, without a little more info, i can guarantee i have no idea.

take a look at this page, strictly for the type of information we’d need. no need to file a bug yet, though it may come to that. tia.

Hi Bill,

My current MaaS version is 3.1.0. What I am trying to do is to deploy a machine located in VMWare with Ubuntu 20.04. The commission goes smoothly and when I try to deploy it, the operation fails “Failed deployment”. Afterwards, I can see in the log this is where it fails:

Marking node failed - Installation failed (refer to the installation log for more information).
Node installation failure - ‘cloudinit’ running modules for final

When I log into the machine, however, it looks completely normal to me. If I go into the cloudinit logs in the machine, I can see that there is an error in, since it complains about the permission denied for the ubuntu user (although it looks like a warning - but it is the only thing similar to an error that I could find).[WARNING]: [Errno 13] Permission denied: ‘/home/ubuntu’

I also tried to reproduce the deployment with Ubuntu 18.04 and 22.04 - all of them gives me failed deployment.

So the problem is that MAAS thinks deployment failed, but you can log into the machine and it looks like deployment did not fail? Do I have that right? In other words, you think MAAS is deploying the image but reporting failure through the UI on a warning?

Yes @billwear , exactly. This is what it looks like. I have deployed before with no problems (like 3 months ago), maybe an update issue?

1 Like

okay, this is clearly a bug; can you please file one against the UI? tia. :slight_smile:

Hi again @billwear, I was about to write right now that when I updated to 3.2 the issue disappeared! Maybe a 3.1 bug? Do you still want me to file a bug or is it not necessary anymore?

1 Like

glad that worked! :slight_smile: this was a painful one.

up to you. if 3.2 fixes it, that’s fine; if you want to be a good citizen and file it, but be clear that you’ve moved on to 3.2 and it goes away, that’s fine too. it might help some other 3.1 user who can’t move forward at some point in the future.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.