maas boot-resources create fails with 'No such file or directory'

Hello!
I cannot create new boot resources.

The command

maas usr boot-resources create name=centos/centos8b title="centos8" architecture=amd64/generic content@=root-tgz

Fails with

[Errno 2] No such file or directory: 'root-tgz'

Yes, the file does exists:

# ls -l root-tgz
-rw-r--r-- 1 root root 550147275 Nov 19 18:05 root-tgz

It is freshly downloaded from images.maas.io for testing purposes. I tried with different setting, different images, including the sha256 and filesize, with a debian image, … always the same error message.

I checked with maas 2.8.2-8577-g.a3e674063 and 2.9/candidate. Both installed with snap running atop Ubuntu 20.04.

Any help is welcome!

Hi @florath,
if you are using a snap maas, maas can only acces to /home and /media (not sure if there is another folder). So you need to put the root.tgz inside of one of these folders.

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.