MAAS 2.7.2 00-maas-01-lshw fail issue

I have MAAS installed and running, however when it tries to commission a machine, it always fails on ‘00-maas-01-lshw’ but I cannot find an error. When I look at the logs, its just displays the xml output of lshw --xml as expected, it also says ‘exit 0’ , I’ve tried commission with 16.04,18.04 and 20.04 all with the same result. I have ssh’d to the machines and ran the 00-maas-01-lshw script manually with no errors. Any suggestions on what might be the issue?


Check the MAAS logs in /var/log/maas. There may be an error processing the results.

Thanks, I was able to install MaaS 2.8.1 and the 00-maas-01-lshw issue seems to have resolved, however now they are failing on ‘50-maas-01-commissioning’ with no obvious errors. /var/log/maas has old log files in it, is there another place where it logs?


You may have migrated to the Snap in which case the logs are stored in /var/snap/maas/common/log

Thanks, looks like I have found the issue, its to do with the winterfell nodes all having the same UUID:

[‘Node with this Hardware uuid already exists.’]

Note sure I can alter that, the dmiedit utility isn’t avaiable for linux, is there a way to have maas use a different identifier? Like /etc/machine-id ?

I actually just answered this in MAAS 2.8/edge - modifying UUID reported by enlisting node

1 Like