Local BIND config on controller not updating from changes in UI


#1

Hello. I’ve installed 2.4 on 18.04 and have it working relatively well, but I’ve noticed that after I use the web ui to modify anything to do with DNS, none of the relevant BIND config files under /etc/bind/maas are being updated. In fact, none have them have been touched since the install.

I tried a completely clean reinstall and notice the exact same behavior. Any change at all in the UI (be it disabling DNSSEC, changing forwarders, adding a host to the maas domain, or adding a new domain) doesn’t touch the BIND config at all, making the DNS UI seemingly useless.

Is there something that has to be done first not mentioned in the install steps? I have everything else working fine; can commission/deploy with no issues.


#2

Is this issue only happening when you are using the Web UI or is the issue reproducable when you are using the API? Could you please file a bug report in https://bugs.launchpad.net/maas/+filebug

And attach:

/var/log/maas/*.log
/var/log/syslog
ls -l /etc/bind
ls -l /etc/bind/maas/


#3

Actually, can you try this:

sudo service maas-regiond restart

Check if the domains you have created are now listed. If they are, go ahead and attempt to create a new domain and see if the issue re-appears?


#4

I was able to reproduce the issue. This can be “fixed” by restarting maas-regiond after fresh install. See https://bugs.launchpad.net/maas/+bug/1807777 for more details.


#5

That actually worked. I had tried rebooting before and that didn’t make a difference. Directly restarting the service did.


#6

To confirm, the issue is present on 2.4.2, and the workaround is to restart maas-regiond. 2.5 is not affected.

Given that 2.5 is around the corner, and will replace 2.4 in ppa:maas/stable, it seems the best path forward would be to upgrade to latest MAAS.