Juju (snap 2.9) will not deploy controller

Hi, hoping someone can provide some breakthrough information to a stuck installation.

We have a MaaS 3.2 install that is working.
We have snap juju 2.9 installed and connected to MaaS.
We have created our cloud and added credentials for MaaS.

We initiate bootstrapping a juju controller (“juju bootstrap cloud controller1”); this gets stuck on “Running machine configuration scripts”, even after days of waiting, still nothing.

The log for the KVM instance shows the final log entry as “Node status event - ‘cloudinit’ running config-fan with frequency once-per-instance”.

I have tried running this with --debug, but no other information showed up as to what is wrong.

We have validated that the machine does have external internet access and we even see it querying external IP’s (firewall packet capture).

Problem solved, there was a NAT issue blocking the controller deployment from finalizing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.