Installin deb MAAS on Ubuntu 20.10 Groovy

Hi, I tried to add the APT repo:
“sudo add-apt-repository” which contains “InRelease” for Groovy, but was never able to install production MAAS with “sudo apt install maas”.

I did run “sudo apt-get update” and it did see the ppa repo of maas for Groovy:

Hit:1 groovy InRelease
Get:2 groovy-updates InRelease [115 kB]
Hit:3 groovy InRelease
Get:4 groovy-backports InRelease [101 kB]
Get:5 groovy-security InRelease [110 kB]
Hit:6 groovy InRelease
Get:7 groovy-updates/main amd64 Packages [405 kB]
Get:8 groovy-updates/universe amd64 Packages [157 kB]
Fetched 887 kB in 1s (1,243 kB/s)
Reading package lists… Done

But when I try to install I get:

:~$ sudo apt-get install maas
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package maas

Anybody knows what I am missing? Anybody has managed to do this?

Thank you,
Luc Lemieux

Hi, MAAS 2.9 from the PPA is only supported on focal.

As a general rule, deb installs are only supported on LTS releases.

If you want to run MAAS on Groovy, you can install from the snap.

Ok, thanks. I need to test what could be a production version and it clearly mentions the Snap is not and I am hopping the stability of the services will be better with deb install because services are going down and never coming back up with the Snap.

Could you describe your issue(s) with the snap?

The snap is an officially supported way of deploying MAAS for production.

Feel free to file bugs on if you encounter issues.

The network interfaces never seem to update. If I install the Snap with the IP address not already on the interface I want to use for node discovery with MAAS managed DHCP, then I have not found a way to get the Controller to detect that IP after the fact.

most of the time some rackd services go down and never come back up even after reboot.

Last week had rackd, httpd, tftpd and dhcpd go down and was never able to get them back up. Had to snap remove maas and mass-test-db and re-install the whole thing. Even just purging the DB and re-installing mass-test-db with a re-init region+rack came back with the services still dead.

Is there a link between database content and actual service status and availability? I mean can a database corruption or badly written data, actually make the services go down and be unable to come back up? Could it be that I am using the Snap DB that is causing instability? I would really doubt it but it could.

I tried stop/starting the Snap, doing “maas refresh” at the command line, can’t get anything to restart the services.

If you do know how, I would be really grateful.

Thank you!

Could you please file a bug including the output of snap info maas and attaching regiond.log and rackd.log from /var/snap/maas/common/logs?


Thank you!